As you probably read in the news, two security vulnerabilities known as “Meltdown” and “Spectre” were recently uncovered. These hardware vulnerabilities affect most computing devices and operating systems in the world. If exploited, these vulnerabilities can allow a rogue application to access other applications running on the same device. At this stage, there is no known report of an attack that could exploit these vulnerabilities. For additional details, please refer to the the Meltdown and Spectre page or the dedicated pages from Google or Apple.

Meltdown and Spectre should in principle not be exploitable on the servers used by Proxyclick to run its application. Indeed, Proxyclick runs on dedicated servers while the vulnerabilities are primarily exploitable on multi-tenant servers (see picture below).   

Still, in a preventive mode and in accordance with its security policy, Proxyclick has applying the security patches released by the major editors following the disclosure of Meltdown and Spectre. 

As a general guideline, we would advise you to check with your IT department if all necessary OS and browser updates have been applied on your infrastructure to address this security vulnerability.


Was this article useful?

This article was not usefulThis article was useful (No Ratings Yet)
Loading ... Loading ...